This came up during code review in https://golang.org/cl/171025.
Backport the improvements to the upstream copies of those packages.
These are better names for these Go packages. The previous names were
an attempt at leveraging the familiarity with Apple's API prefixes
(i.e., AppKit identifiers tend to have "NS" prefix, Core Animation API
identifiers tend to have "CA" prefixes). However, that isn't as useful
here because those prefixes are not very consistent or recognizable
when turned into Go package names.
Create a helper to convert from bool to C.BOOL and use it instead of
more verbose switches. Other people seem to like this style better.